Issues across the platform due to AWS outage

Incident Report for Insurance Quantified

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:00 EDT

Monitoring

AWS has implemented fixes (https://health.aws.amazon.com/health/status). We will continue to monitor services internally until resolved.
Posted Oct 20, 2025 - 16:48 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:58 EDT

Identified

We are experiencing intermittent issues due to the AWS and Atlassian outages.
Posted Oct 20, 2025 - 03:00 EDT
This incident affected: IQOS (Workbench Prod) and Groundspeed (Document Intake, Data Ingestion, Data Enrichment, Data Extract and Delivery).