Increased latency in document ingestion

Incident Report for Insurance Quantified

Resolved

This incident has been resolved.
Posted Oct 04, 2024 - 10:28 EDT

Investigating

We are currently investigating this issue.
Posted Oct 04, 2024 - 09:56 EDT
This incident affected: Groundspeed (Document Intake).